Okay
  Public Ticket #2607829
Question About Sonaar MP3 Player Preloading Files
Open

Comments

  • Leandro started the conversation

    Hi. I just deployed my new website to live using the Sonaar theme but I ran some speed tests and noticed that for some reason (maybe a misconfiguration from my part, dunno) if you open a playlist page that you set to automatically pop up the mp3 player after the page loads, the actual MP3 file used in the player is preloaded, which causes the page to always transfer quite a lot of data (the main page content + the entire MP3). Thing is, this happens even before you click the play button, and in my case autoplay is disabled too.

    What is interesting is that this behavior does not seem to happen in the podcast pages with the same settings. For podcasts, the player pops up just fine, but the actual file is only loaded when you click play. There is still a partial "http 206" request, but in this case it makes sense since the podcast is way longer than a playlist file.

    My question is: is there any way to disable this behavior without disabling the automatic pop up player from showing?

    My files are all hosted on Amazon S3 if that helps.

    Thanks!

  •  388
    Max replied

    Hi,

    when I go to your website, I see a coming soon page which prevent me to reproduce your issue on my computer. Could you please provide me access to your wp-admin or remove the coming soon page?

    Thanks,


    Max from the Sonaar.io Crew

  • Leandro replied

    Hi Max, thanks for the reply. Here is one playlist url that has the player on:

    https://tiosolid.com/release/drumkit-ramblings


    if you check the developer settings, you will see the partial downloads when the player opens. Its still a partial download (206) but still like 3MB of data. If there is a way to pop up the player automatically without this preload, that would be really preferable. Thanks!

    Attached files:  Untitled.png

  •  388
    Max replied

    Hi,

    Im trying to replicate the issue on my end to make sure I correctly understand.

    which browser are you using? Im using latest version of Chrome and I dont see any MP3 loading in my console: https://d.pr/i/YYFEP8

    Thanks,


    Max from the Sonaar.io Crew

  • Leandro replied

    damn site is cursed then 🤣

    Im also using latest Chrome version on Windows 10, that is really weird.

    Could you try on https://tiosolid.com/mix/definitive-vocals-vol-13 for example? All the mixes from here https://tiosolid.com/mixes/definitive-vocals have the player enabled and show the same behavior for me.


    Attached a new screenshot so you can see what I see here. Thanks!

    Attached files:  site.png

  •  388
    Max replied

    Sorry Leandro, id like to help but I cant replicate it. See video recording i've made: https://d.pr/v/PYMS56

    Thanks,


    Max from the Sonaar.io Crew

  • Leandro replied

    That is a really strange behavior.. Well, maybe is something on my browser or network then. Thanks anyway for the help!