Okay
  Public Ticket #2828327
Music Player Pro Update
Closed

Comments

  • GRIGORIOS S LAGIOS started the conversation

    until today I had the freer player on my site, I bought the Pro version. In my activation comes the message "Plugin could not be activated because it triggered a fatal error."
    do i have to delete the free version ??
    wordpress and PHP are up to date.
    can i back up the playlist I have created ??

  •  529
    Max replied

    Hi

    Could you please provide me access to your wp-admin and I will gladly check the issue you have.


    Thanks,


    Max from the Sonaar.io Crew

  • GRIGORIOS S LAGIOS replied

    thank you for the response. I finally did it by installing the free version from the beginning and then the Pro. But I would like to ask if the player can auto start without having to press Play button. TY

  •  529
    Max replied

    Auto-play audio when your page loads is now banned by most desktop and mobile browsers including Chrome and Safari. This is what we call a "Auto-Play Policy". To play audio in a web browser, the user has to interact with the page before audio can play. Interactions is something like clicking a menu, a button, scroll down the page, etc.

    The closest thing you can do is to automatically fire the sticky footer player when the page load and then, users will have to click play. To do it, edit your page and select your playlist in the Music dropdown. See screenshot: https://d.pr/i/ouq7Ay

    You can read more about the Chrome browser policy here: https://www.theoplayer.com/blog/chrome-autoplay-policy-what-you-need-to-know

    Thanks,


    Max from the Sonaar.io Crew

  • GRIGORIOS S LAGIOS replied

    in my Albums in the parameter where to buy I have as options: spotify, Apple Music, Bandcamp and Store. In Sticky Footer Player only shows me Bandcamp and Store .... why ??

  •  529
    Max replied

    Hi,

    I can't seem to be able to reproduce on my computer. See screenshot: https://d.pr/i/umuuaK

    Perhaps try to clear your browser cache maybe. If it still does not work, could you please elaborate on the steps to reproduce the issue on my end and I will check this for you.


    Thanks,


    Max from the Sonaar.io Crew

  • GRIGORIOS S LAGIOS replied

    Thanks again for response. I reload and resave my albums and now all works fine :)