Public Ticket #3300194
Playback not working


  • maestro2805 started the conversation

    Since updating to version 4.4 playback is not working at all.
    When I edit with "Elementor", then playback works on the editing page.
    When I preview, nothing happens.
    I'm using an external URL to load my files. Up until now, it all worked fine.


    The audio plays back in Chrome, but not in Firefox (These files are local, stored on Wordpress Media).

    I desperately need help with this problem.

    Other page examples:

  •  865
    Max replied


    You have a CORS policy error. 

    Please read this : https://sonaar.io/docs/audio-not-playing-read-this/


    Max from the Sonaar.io Crew

  • maestro2805 replied

    Thanks for your reply.
    You've recognized the problem, how can I fix it? I'm not at all experienced with this sort of thing.
    This started happening since I updated your product. Surely you tell me what to do? Rather than point me in another direction,
    Is this something that can be fixed by my provider?

  •  865
    Max replied

    Yes, as stated in the documentation:

    Solution 3 – Configure the server hosting the audio file (which in your case is https://audio.russellharris.de/) to allow cross-origin requests by adding the appropriate CORS headers to the server response. You may want to reach your hosting provider for this. The exact headers needed depend on the server configuration, but generally involve allowing the Origin header and specifying which domains are allowed to make cross-origin requests.

    The server hosting the audio file needs to add the appropriate CORS headers to the server response, which allows the browser to load the file and share resources across different domains.

    You can also send this article to your hosting provider.


    Max from the Sonaar.io Crew

  •  1
    Megan replied

    Updating the below comment, in case anyone else is looking for this answer! Just figured out that it is the AmazonS3, where the audio is served from, that needs the CORS header, not the website/host.

    (Found instructions here https://docs.aws.amazon.com/sdk-for-javascript/v2/developer-guide/cors.html and going to try to figure out how to do that now!) hopefully this will solve the playback issue.


    I am having this issue after updating as well. I followed this "Solution 3" and have added the CORS headers (followed this https://eu.siteground.com/kb/cross-origin-resource-sharing-cors/ and disabled the NGINX Direct Delivery.

    The audio still is not functioning as it was before update, no sound.

    Any other suggestions? (I tried disabling other plugins but did not help so far).


  •  865
    Max replied

    @Megan: Cors header are not correctly set on your aak-raga-radio.s3.us-west-1.amazonaws.com provider. Please contact your amazon support for this if you are not familiar with cors.


    Max from the Sonaar.io Crew